Forgot your password?    
+ Reply to Thread
Results 1 to 7 of 7

Thread: 11.5.10 installation fixes on OEL5 or RHEL5

  1. #1
    Expert Oracle Administrator
    Join Date
    Oct 2011
    Location
    New Delhi, India
    Posts
    426

    11.5.10 installation fixes on OEL5 or RHEL5

    Install the following non-standard packages:

    The following packages are not part of the OEL 5 or RHEL 5 distribution media and must be installed manually:

    * compat-libstdc++-egcs-1.1.2-11
    * compat-libcwait-2.1-11
    * compat-oracle-el5-1.0-51
    * openmotif21-2.1.30-11.EL51
    * binutils-2.152

    The following packages must be installed from the OEL 5 or RHEL 5 distribution media:

    * libXp-1.0.0-8.1.el5
    * compat-libgcc-296-2.96-138
    * compat-libstdc++-33-3.2.3-61
    * compat-db-4.2.52-5.1

    Comment out the /lib/libcwait.so line from /etc/ld.so.preload.

    For Oracle Enterprise Linux 5, Red Hat Enterprise Linux 5 and SUSE Linux Enterprise Server 10 customers, the LD_ASSUME_KERNEL environment variable should be unset before starting the installation. The installation fails when the LD_ASSUME_KERNEL variable is set by the adgetlnxver.sh file during the course of the installation. Patch 6365595 contains the fix for adgetlnxver.sh file. The procedure below is a guideline for replacing the adgetlnxver.sh file in the Oracle Applications 11i shiphome.

    1. Download the patch 6365595 from OracleMetalink.

    2. Follow the Oracle Applications Installation guide and set up the stage area.

    3. Set the STAGE_TOP environment variable to the top level directory of the stage area that contains the subdirectories startCD, oraApps, oraDB, oraiAS and oraAppDB. Make sure that the stage area is read writable.

    # export STAGE_TOP=/stage/software/stage11i10.2
    # export PATCH_TOP=/stage/software/stage11i10.2/oel5rpms/6365595

    4. Create the following directories in the stage area.
    # mkdir -p $STAGE_TOP/oraDB/Disk3/db/stage/appsutil/bin
    # mkdir -p $STAGE_TOP/oraApps/Disk5/appl/stage/bin

    5. Copy the adgetlnxver.sh file in the patch 6365595 to the following directories created in earlier step.
    # cp -p $PATCH_TOP/ad/bin/adgetlnxver.sh $STAGE_TOP/oraDB/Disk3/db/stage/appsutil/bin
    # cp -p $PATCH_TOP/ad/bin/adgetlnxver.sh $STAGE_TOP/oraApps/Disk5/appl/stage/bin

    6. Update the zip archive with the fix (adgetlnxver.sh file).
    # cd $STAGE_TOP/oraDB/Disk3/db/stage
    # zip -u dboh0_appsutil appsutil/bin/adgetlnxver.sh
    # cd $STAGE_TOP/oraApps/Disk5/appl/stage
    # zip -u ad_CORE bin/adgetlnxver.sh

    For Oracle Enterprise Linux 5 and Red Hat Enterprise Linux 5 only :

    # ln -s /usr/bin/ld215 /usr/bin/ld
    Download and apply the OS library patch 6078836 from OracleMetaLink and create the following symbolic link:
    # ln -s /usr/lib/libdb.so.2 /usr/lib/libdb.so.3

    # Verify that the host name setting is correct. The command should return a fully qualified host name. For example: <host_name>.<domain_name>.

    # hostname -f


    ./rapidwiz

    Rapid Install Wizard is validating your file system......
    Rapid Install Wizard will now launch the Java Interface.....

    [root@oel53ebs64 rapidwiz]# /stage/software/stage11i10.2/startCD/Disk1/rapidwiz/jre/Linux/1.4.2/bin/jre: error while loading shared libraries: libpthread.so.0: cannot open shared object file: No such file or directory

    For Oracle Enteprise Linux and Red Hat Enteprise Linux 5 Update 3 (5.3), users will see a failure when running Rapid Install. Users must edit the file $STAGE_TOP/startCD/Disk1/rapidwiz/bin/runWizard.sh and comment out lines 122-125, as in:

    # if test "$exit_code" == "0" ; then
    # LD_ASSUME_KERNEL=2.4.19
    # export LD_ASSUME_KERNEL
    # fi

    [root@appserver rapidwiz]# ./rapidwiz

    Rapid Install Wizard is validating your file system......
    Rapid Install Wizard will now launch the Java Interface.....
    ...
    These utilities need to be accessible on your system in order to do administrative tasks.

    command : /stage/software/stage11i10.2/startCD/Disk1/rapidwiz/bin/adchkutl.sh

    Checking for make... found - /usr/bin/make
    Checking for ld... found - /usr/bin/ld
    Checking for cc... found - /usr/bin/cc
    Checking for ar... found - /usr/bin/ar
    Checking for ksh... found - PD KSH
    Utility check completed successfully

    System Utilities Availability test has succeeded


    Here is the zip file which contains these
    RPMs to install on OEL5 / RHEL5 32 bit Linux : rpm_for_RHEL5_OEL5.zip
    ===============================================

    binutils-2.17.50.0.6-6.0.1.el5.i386.rpm
    binutils-2.17.50.0.6-9.0.1.el5.i386.rpm
    compat-binutils215-2.15.92.0.2-24.i386.rpm
    compat-gcc-296-2.96-138.src.rpm
    compat-libcwait-2.1-1.i386.rpm
    compat-libgcc-296-2.96-138.i386.rpm
    compat-libstdc++-296-2.96-138.i386.rpm
    compat-libstdc++-3.2-1.i386.rpm
    compat-libstdc++-33-3.2.3-61.i386.rpm
    compat-libstdc++-egcs-1.1.2-1.i386.rpm
    compat-oracle-el5-1.0-5.i386.rpm
    openmotif21-2.1.30-11.EL5.i386.rpm
    openmotif21-debuginfo-2.1.30-11.EL5.i386.rpm

  2. #2
    Oracle DBA
    Join Date
    Oct 2011
    Posts
    21
    Ref: On RHEL5

    Hi Sir,

    I have installed the two patches (6365595 & 6078836), however, I am unable to find the packages on metalink/google which you have mentioned (The following packages are not part of the OEL 5 or RHEL 5 distribution media and must be installed manually:

    * compat-libstdc++-egcs-1.1.2-11
    * compat-libcwait-2.1-11
    * compat-oracle-el5-1.0-51
    * openmotif21-2.1.30-11.EL51
    * binutils-2.152

    The following packages must be installed from the OEL 5 or RHEL 5 distribution media:

    * libXp-1.0.0-8.1.el5
    * compat-libgcc-296-2.96-138
    * compat-libstdc++-33-3.2.3-61
    * compat-db-4.2.52-5.1

    Comment out the /lib/libcwait.so line from /etc/ld.so.preload)

    I am also unable to find the file to comment (Comment out the /lib/libcwait.so line from /etc/ld.so.preload).

    Please help.

    Vipul

  3. #3
    Expert Oracle Administrator
    Join Date
    Oct 2011
    Location
    New Delhi, India
    Posts
    426
    Most of the rpms can be found on : http://rpm.pbone.net/index.php3

    Oracle related packages are available on http://oss.oracle.com/

  4. #4
    Oracle DBA
    Join Date
    Oct 2011
    Posts
    21

    Smile Ref: On RHEL5

    Hi,

    I was able to get the find and install the non-standard packages, however, still I was getting the error of 'unable to locate ksh shell' during re-requisite check.

    I did two things:
    1. export KSH_VERSION='@(#)PD KSH v5.2.14 99/07/13.2'

    2. Installation checks for ' PD KSH' and that's not installed when installing Oracle Linux 5.
    I removed the ksh check from the script by commenting the ksh find in adchkutl.sh script.

    checked the adchkutl.sh script and commented :

    ## Verify for ksh if its a linux only platform#
    if test $UNAME = "Linux"; then
    printf "Checking for ksh...\t";
    VERSN=`/bin/ksh -c 'echo $KSH_VERSION' grep "PD KSH";`;
    EC=$?
    if test $EC != "0" ; then
    printf "\nUnable to find 'kshell' in path\n";
    SHOW_PATH=1
    else
    printf "found - $VERSN\n";
    fi
    fi


    It worked. :-)

    Vipul
    Last edited by Hemant; 11-21-2011 at 10:17 AM.

  5. #5
    Oracle Administrator
    Join Date
    Oct 2011
    Posts
    43
    Hi I am getting the follwing error while trying to install apps 11i
    I have checked the permissions on /tmp and also changed them but still getting this error again and again also whenever i launch rapidwiz it kicks me out of the ORACLE user through which i always launch the installation Pls help

    . ./rapidwiz


    Rapid Install Wizard is validating your file system......
    dirname: invalid option -- b
    Try `dirname --help' for more information.
    rm: cannot remove `/tmp/oraInstRoot.sh': Operation not permitted
    Rapid Install Wizard will now launch the Java Interface.....

  6. #6
    Oracle Administrator
    Join Date
    Oct 2011
    Posts
    43
    Any post on this???

  7. #7
    Expert Oracle Administrator
    Join Date
    Oct 2011
    Location
    New Delhi, India
    Posts
    426
    Please check the owner of this file `/tmp/oraInstRoot.sh'.
    It is probably not owned by Oracle user and hence the problem in removing this file.

    Remove this file as root / or the user who is the owner and retry the operation.

+ Reply to Thread

Similar Threads

  1. FRM-92050 Forms Error In RHEL5
    By aryan in forum Concepts,Service Management,Apache,OC4J,OPMN,JServ,Forms, Issues,Troubleshooting,
    Replies: 0
    Last Post: 03-29-2012, 05:39 PM
  2. Configuring yum in RHEL5.
    By ajaychandi in forum OS for Oracle Administration
    Replies: 0
    Last Post: 01-31-2012, 08:57 PM
  3. Adding a new partition in RHEL5
    By shoaibansari in forum OS for Oracle Administration
    Replies: 1
    Last Post: 12-25-2011, 10:53 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

DBA Lounge (P) Ltd. deals in Oracle Technologies on Consulting, Resourcing, Corporate Training


Online and corporate training available on Oracle Database 11g, Oracle 11g Real Application Cluster (RAC), Oracle Applications 11i/R12, Oracle Fusion Middleware 11g, Oracle Identity Management-OIM, Oracle Internet Directory 11g-OID, Oracle Business Intelligence Enterprise Edition-OBIEE, Oracle Golden Gate, Oracle Access Management-OAM, Oracle Internet Directory-ODS, Oracle Identity Analytics Architecture-OIA Statistics