1. Why is recommended to have applied the last version of the AD.I ?
This minipack provide you with the last version of the Oracle Applications DBA utilities. Theoretically there are less bugs in the last AD version, so is preferred to use the last AD version.

2. What is the AD.I I use currently ?

Run this query to know the AD.I Version.

col Application_Name format a45
col PATCH_LEVEL format a12
SELECT fa.application_name "Application_Name",
fpi.patch_level Patch_Level
FROM fnd_application_all_view fa,
fnd_product_installations fpi
WHERE fa.application_id = fpi.application_id
AND fpi.patch_level like '%AD.I%' ;

3. How Could I install/apply the last AD.I version ?

To be sure that the patch is applied successfully, please see the Metalink Note 233044.1

For an initial full 11.5.10.2 Oracle Apps version on Oracle Linux Unbreakable (RH kernel) here are the steps I followed:

A) Prerequisites
Nothing to do.

B) APPLY the Minipack
Apply the last AD.I patch. In my case the last AD.I patch is 6502082 (for the AD.I.6).

C) Post-minipack Steps
a) Create $ORACLE_HOME/appsutil/admin on the database server.
$ mkdir $ORACLE_HOME/appsutil/admin
b) Copy adgrants.sql (UNIX) from $APPL_TOP/admin to $ORACLE_HOME/appsutil/admin.
(For Windows :adgrants_nt.sql )
c) Source the database environment
In my case:
. /APPS_DB/visdb/9.2.0/VIS_db.env
d) Run adgrants.sql
[oracle@DB appsutil]$ sqlplus /nolog
SQL*Plus: Release 9.2.0.6.0 - Production on Sat Apr 19 12:29:34 2008
Copyright (c) 1982, 2002, Oracle Corporation. All rights reserved.
SQL> connect / as sysdba
Connected.
SQL> @$ORACLE_HOME/appsutil/admin/adgrants.sql APPLSYS

e) Unzip apps.zip under $JAVA_TOP (conditionally required)
[applmgr@apps /]$ cd $JAVA_TOP
[applmgr@apps java]$ pwd
/APPS_MI/viscomn/java
[applmgr@apps java]$ ls | grep apps.zip
apps.zip.bak

Because the apps.zip have been already unzipped (if the file wasn't unzipped the file must be there), go on to Step f).
NOTE:
If you are unzipping apps.zip as a post-minipack step, you must apply patch (5161676). This patch includes a driver file
(explode.drv) that unzips apps.zip. If you do not apply this patch, the Maintain Snapshot functionality will not work correctly.

f) Run AutoConfig
If your system is enabled to use AutoConfig, run AutoConfig to instantiate the templates used by the AD utilities.
After you apply this minipack, AutoPatch automatically runs AutoConfig during each patch session; however you can run the AutoConfig again if you want.

4. Verify again the current version of the AD.I.